Back to overview
Downtime
Service Outage
Dec 11 at 05:18am MST
Affected services
pixelfed.social
Resolved
Dec 11 at 05:50am MST
Service is restored
Affected services
pixelfed.social
Updated
Dec 11 at 05:48am MST
Service will be restored in the next 20 minutes
Affected services
pixelfed.social
Created
Dec 11 at 05:18am MST
We are performing some maintenance, service will resume shortly.
Affected services
pixelfed.social